Vista Blues – sluggish PC!



September 10th, 2007 by Kat Kingsley-Hughes

My PC is running so sloooowly it’s like trying to work in a vat of treacle – although not so tasty! 😉  Adrian and I both ran process explorer and compared results.  For some reason pretty much every running process that we have in common is taking 10–20MB extra memory on my Vista PC than his. 

Process explorerHe has more RAM than I do and a slightly faster processor.  He also has less hardware attached to his PC than I do eg. Canoscan LiDE scanner, Wacom Intuos graphics tablet, Logitech G15 keyboard, MX518 mouse, Hauppauge WinTV card and all their associated drivers and run at startup services plus numerous MP3 device-related applications.  Sure I’ve got a lot more crap running than he does and I could free up a lot of juice if I shut off some of those annoying services that run purely in order to keep their application in my face all day rather than offering me any extra facility by taking up all my RAM. 

But I’m just really stumped – after much searching neither of  us can figure out why every process is eating more memory on my PC than his. 

Board4quadandfanI’m not going to stress about it.  After finishing the build, I’ll be settling down to get my installation up and running on my new Quad Core PC this week.  So even if I didn’t have a new PC to look forward to I’d still be planning on spending my week installing Vista and all my applications.  Sometimes it’s not worth fighting with these things.   (My current PC will get downgraded to XP – one Vista PC headache is more than enough!)

This entry was posted on Monday, September 10th, 2007 at 3:30 am and is filed under Flotsam, Hardware, Windows. Both comments and pings are currently closed.

Comments are closed.

%d bloggers like this: